06月03, 2019

webpack 打包过后的文件报错 regeneratorRuntime is not defined

babel基础包(不安装额外东西)并不是支持完整的es6语言,加上浏览器也不是支持所有的es6语言,如果你写的es6语言刚好撞上这样的情况了.


那么就需要babel的拓展包babel-plugin-transform-runtime

 yarn add babel-plugin-transform-runtime

plugins中的配置

 "plugins": [
    "@babel/plugin-transform-runtime"
  ] 

本文链接:http://h88829.top/post/webpack-regeneratorRuntime.html

-- EOF --

Comments